cubicsdr

Post information or questions regarding SDRplay products here
arcosine
Posts: 30
Joined: Wed Jan 02, 2019 6:24 pm
Location: 41.678472, -88.051762

cubicsdr

Postby arcosine » Wed Jan 02, 2019 6:39 pm

Hi,

I have the RSP1 and I installed CubicSDR on Linux Mint. I find the program to be lacking, no CW mode, many false images in the waterfall and poor side band reaction. Is there any other software that I can install. I see OpenWebRX supports SDRPlay, and it looks good on the web, but after following the instructions, it doesn't work. Maybe it needs a driver somewhere?
I copied and pasted these instructions: https://blog.sdr.hu/2015/06/30/quick-se ... webrx.html

And get this result:

nmux: listening on 127.0.0.1:4951
No supported devices found.
nmux: (main thread/for) end input stream, exiting.

Tony
Last edited by arcosine on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Tony
AA9CC

fventuri
Posts: 37
Joined: Sun Dec 25, 2016 4:24 pm

Re: cubicsdr

Postby fventuri » Thu Jan 03, 2019 3:41 am

Tony,
I saw your post about OpenWebRX this evening and I wanted to give it a try.
I followed all the instructions (SDRPlay drivers for Linux, SoapySDR, SoapySDRPlay, rx_tools, csdr, and finally openwebrx) and I can tell OpenWebRX can see the RSP2:

Code: Select all

./openwebrx.py


OpenWebRX - Open Source SDR Web App for Everyone!  | for license see LICENSE file in the package
_________________________________________________________________________________________________

Author contact info:    Andras Retzler, HA7ILM <randras@sdr.hu>

[openwebrx-main] Configuration script not specified. I will use: "config_webrx.py"
[openwebrx-main] nmux_bufsize = 503808, nmux_bufcnt = 100
[openwebrx-main] Started rtl_thread: rx_sdr -F CF32 -s 2000000 -f 89900000 -p 0 -g 5 -| nmux --bufsize 503808 --bufcnt 100 --port 4951 --address 127.0.0.1
[openwebrx-main] Waiting for I/Q server to start...
nmux: listening on 127.0.0.1:4951
[openwebrx-main] I/Q server started.
[openwebrx-main] Starting watchdog threads.
nmux: pthread_create() done, clients now: 1
client 0x105d2a0: started!
[openwebrx-main] Starting spectrum thread.
[openwebrx-spectrum] Spectrum thread initialized successfully.
[openwebrx-dsp-plugin:csdr] Command = nc -v 127.0.0.1 4951 | csdr fft_cc 4096 2849 | csdr logaveragepower_cf -70 4096 78 | csdr fft_exchange_sides_ff 4096 | csdr compress_fft_adpcm_f_u8 4096
[openwebrx-spectrum] Spectrum thread started.
Ncat: Version 7.70 ( https://nmap.org/ncat )
Ncat: Connected to 127.0.0.1:4951.
nmux: pthread_create() done, clients now: 2
client 0x105dbe0: started!
[openwebrx-main] Starting HTTP server.
Using device **********: mir_sdr_api_version=2.130000 mir_sdr_hw_version=2
Found 3 antenna(s): Antenna A Antenna B Hi-Z
Found 2 gain(s): IFGR RFGR
Found 2 frequencies: RF CORR
Found 13 sample rates: 250000 500000 1000000 2000000 2048000 3000000 4000000 5000000 6000000 7000000 8000000 9000000 10000000
Found 8 bandwidths: 200000 300000 600000 1536000 5000000 6000000 7000000 8000000
[INFO] Using format CS16.
Using output format: CF32 (input format CS16)
...

However when I try to connect to it going to this URL with the browser: http://localhost:8073, "something" still doesn't work, and I see this message in the terminal where I started ./openwebrx.py:

Code: Select all

free(): double free detected in tcache 2

I looked up that message in Google and it might be a bug in the version of Linux I am running here (Fedora 29), so it might not happen to you, since you are using a different version of Linux.

In order to troubleshoot your problem, I would suggest that you run the two test commands that are shown here: https://github.com/simonyiszk/openwebrx/wiki/Using-SoapySDR-via-rx_tools-with-OpenWebRX#step-3-test-the-sdr-device

Code: Select all

SoapySDRUtil --find
rx_sdr - | csdr through > /dev/null

The output from these commands should look more or less like this:

Code: Select all

SoapySDRUtil --find

######################################################
##     Soapy SDR -- the SDR abstraction library     ##
######################################################

Found device 0
  driver = sdrplay
  label = SDRplay Dev0 RSP2 **********


rx_sdr - | csdr through > /dev/null

Using device **********: mir_sdr_api_version=2.130000 mir_sdr_hw_version=2
Found 3 antenna(s): Antenna A Antenna B Hi-Z
Found 2 gain(s): IFGR RFGR
Found 2 frequencies: RF CORR
Found 13 sample rates: 250000 500000 1000000 2000000 2048000 3000000 4000000 5000000 6000000 7000000 8000000 9000000 10000000
Found 8 bandwidths: 200000 300000 600000 1536000 5000000 6000000 7000000 8000000
[INFO] Using format CS16.
Using output format: CU8 (input format CS16)
Sampling at 2048000 S/s.
Tuned to 100000000 Hz.
Reading samples in sync mode...
through: 3975585 bytes/s, buffer #976
...


Hope this helps,
Franco

Reason: No reason

arcosine
Posts: 30
Joined: Wed Jan 02, 2019 6:24 pm
Location: 41.678472, -88.051762

Re: cubicsdr

Postby arcosine » Thu Jan 03, 2019 5:25 pm

Hi Franco,

i tried your suggestion. I had to reset my root password and then relearn use of the vi editor and got to the last line, python2 openwebrx.py and got this result in the terminal window:

OpenWebRX - Open Source SDR Web App for Everyone! | for license see LICENSE file in the package
_________________________________________________________________________________________________

Author contact info: Andras Retzler, HA7ILM <randras@sdr.hu>

[openwebrx-main] Configuration script not specified. I will use: "config_webrx.py"
[openwebrx-main] nmux_bufsize = 602112, nmux_bufcnt = 84
[openwebrx-main] Started rtl_thread: rx_sdr -F CF32 -s 2400000 -f 144250000 -p 0 -g 5 -| nmux --bufsize 602112 --bufcnt 84 --port 4951 --address 127.0.0.1
[openwebrx-main] Waiting for I/Q server to start...
nmux: listening on 127.0.0.1:4951
[openwebrx-main] I/Q server started.
[openwebrx-main] Starting watchdog threads.
nmux: pthread_create() done, clients now: 1
client 0x2414fe0: started!
[openwebrx-main] Starting spectrum thread.
[openwebrx-spectrum] Spectrum thread initialized successfully.
[openwebrx-dsp-plugin:csdr] Command = nc -v 127.0.0.1 4951 | csdr convert_u8_f | csdr fft_cc 4096 2867 | csdr logaveragepower_cf -70 4096 93 | csdr fft_exchange_sides_ff 4096 | csdr compress_fft_adpcm_f_u8 4096
[openwebrx-main] Starting HTTP server.
[openwebrx-spectrum] Spectrum thread started.
nmux: pthread_create() done, clients now: 2
client 0x24151a0: started!
Connection to 127.0.0.1 4951 port [tcp/*] succeeded!
Using device 1807096593: mir_sdr_api_version=2.130000 mir_sdr_hw_version=255
Found 1 antenna(s): RX
Found 2 gain(s): IFGR RFGR
Found 2 frequencies: RF CORR
Found 13 sample rates: 250000 500000 1000000 2000000 2048000 3000000 4000000 5000000 6000000 7000000 8000000 9000000 10000000
Found 8 bandwidths: 200000 300000 600000 1536000 5000000 6000000 7000000 8000000
[INFO] Using format CS16.
Using output format: CF32 (input format CS16)
Sampling at 2400000 S/s.
Tuned to 144250000 Hz.
Tuner gain set to 5.00 dB.
Reading samples in sync mode...
client 0x2414fe0: CS_THREAD_FINISHED, client_goto_source = 2, errno = 32


And that's all she wrote. Just kind of sat there, dont know what error no 32 is. System monitor says rx_sdr running, using 357 MiB but there's no window or indication.
Last edited by arcosine on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Tony
AA9CC

fventuri
Posts: 37
Joined: Sun Dec 25, 2016 4:24 pm

Re: cubicsdr

Postby fventuri » Fri Jan 04, 2019 2:31 am

Tony,
very good; you are on the right track!

From your output from OpenWebRX, I can clearly see it is recognizing your SDRPlay RSP:

Code: Select all

Using device 1807096593: mir_sdr_api_version=2.130000 mir_sdr_hw_version=255

Now remember this is a web SDR, so in order to "see" it you have to open a browser and go to this URL: http://localhost:8073 (assuming you didn't change the default port number (parameter: web_port) in the file 'config_webrx.py'). Of course this URL will only work if you are running the browser on the same computer where OpenWebRX is running, otherwise your URL will be something like http://192.168.x.y:8073 (where 192.168.x.y is the IP address of the computer running OpenWebRX).

As per the error message I received last night: 'free(): double free detected in tcache 2', I did some more research before going to bed, and I found it is actually caused by a bug in 'nmux' (which is one of the programs that are compiled under 'csdr'). The bug is fully described in this GitHub issue: https://github.com/simonyiszk/csdr/issues/40 and fortunately in the same page there's a patch (https://github.com/simonyiszk/csdr/issues/40#issuecomment-426306446), that fixed that problem for me. I applied the patch in 'csdr', re-ran 'make', and 'sudo make install', and after that I didn't get that error and I was able to see my RSP2 using OpenWebRX and connecting with the browser (waterfall, sound in the headphones, etc)

Let me know how if goes,
Franco

Reason: No reason

arcosine
Posts: 30
Joined: Wed Jan 02, 2019 6:24 pm
Location: 41.678472, -88.051762

Re: cubicsdr

Postby arcosine » Sat Jan 05, 2019 12:56 am

Hi Franco

I don't know why my last post dint show. I think every post has to be approved by a moderator? Ive never herd of that before. That makes things very slow, and well, censored .

Yes, in Firefox localhost: 8073 has the waterfall, but its mostly noise, very little signal, if any. Some things need to be set in the config file. I tried playing with some of the parameters but really didn't help, rf gain, sample rate, agc level ect. If I can find the config file for Cubicsdr, that will give me some parameters to try to add.

I'm using Linux Mint 18.2, Sonya 64-bit Kernel Linux 4.8.0-53-generic x86_64, MATE 1.18.0

I have virtualbox, Im thinking of tying sdrplay's windows software on it.

Tony
Last edited by arcosine on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Tony
AA9CC


Return to “SDRplay related”

Who is online

Users browsing this forum: No registered users and 2 guests