Page 1 of 1

SoapySDR Error Compiling GR-OSMOSDR

Posted: Sat May 27, 2017 1:24 pm
by yagigain
Not happy with the performance of the R2 with GNU Radio I decided to try SoapySDR, but I can't get past this error, been at it all day.

I have installed SoapySDR and SoapySDRPlay .. Soapy sees the SDRPlay R2 device ok. I need it working via gr-osmosdr though .. when I compile gr-osmosdr I get this errror,

CMake Error at /home/gnu/Downloads/prefix/default/SoapySDR/cmake/SoapySDRConfig.cmake:161 (message):
cannot find SoapySDR library in /home/gnu/Downloads/prefix/lib

Any ideas ... I am about all out .. going to plug the Airspy back in for a while !

Re: SoapySDR Error Compiling GR-OSMOSDR

Posted: Sat May 27, 2017 2:35 pm
by octave9
No idea really and my Linux PC doesn't get used for SDRplay, but there are bits of installs on the system and I did a 'locate osmosdr' which shows where there are some libs:

$ locate osmosdr

The last one may be the one your cmake fails to find.

Re: SoapySDR Error Compiling GR-OSMOSDR

Posted: Sat May 27, 2017 4:15 pm
by yagigain
Thanks, I tried forcing the lib path and it solved it .. however it then couldn't find the includes path .. so I forced that and now its saying it can't find the package. hmmm, Seems like there is some underlaying problem.

I have the R2 working with gr-osmsdr but the performance is poor compared to my airspy ... i think I need Soapy to get the R2 supported properly.

I might start over .. how would I remove the compiled SoapySDR ?

Re: SoapySDR Error Compiling GR-OSMOSDR

Posted: Sun May 28, 2017 7:45 am
by octave9
There's an 'uninstall' target in the SoapySDR Makefile, so you can use that to remove it. There isn't one for SoapySDRPlay, but I don't think it does much more than install a lib, which you could manually remove. This was how the install of the latter went for me:

[100%] Built target sdrPlaySupport
Install the project...
-- Install configuration: "Release"
-- Installing: /usr/local/lib/SoapySDR/modules0.6-dev/
-- Set runtime path of "/usr/local/lib/SoapySDR/modules0.6-dev/" to ""

Hoping reinstallation improves it, but I find it's really hard to be fully objective when comparing two radios...