Virtual Trackgen

Information and discussions on Spectrum Analysis
SteveAndrew
Posts: 213
Joined: Thu Nov 16, 2017 11:06 pm
Location: Gold Coast, QLD, Australia

Virtual Trackgen

Post by SteveAndrew » Fri Jun 22, 2018 10:00 am

Hi

I've had a couple of inquiries regarding driving external signal generators that are not connected to an Arduino that's running the Trackgen firmware.

For those who are interested in using the analyser's tracking generator commands to drive their own generator hardware, I've written a simple demo application in C# that shows how you can communicate with the analyser using virtual comms ports. This will allow those using something apart from an AD9850 or an AD9851 to write driver code for their own generator and connect it to the analyser.

The code is not bullet-proof and is provided only as a demonstration. All the information you will need is included in the source file, including a link to where you can download the com0com virtual comms port system.

There are several boards available on Ebay, and other places that are using the AD9959 DDS such as:

https://www.ebay.com.au/itm/NEW-AD9959- ... SwIJlaENQa

and

https://www.ebay.com.au/itm/AD9959-DDS- ... SwmgJY1SUd

The second board includes a USB interface card. I have no information regarding how the USB link works, but as it will almost certainly be comms-driven, that should make it easy to interface to the analyser. If anybody has one of these boards, I'd be grateful for any details, particularly the USB version.

You should be able to place the unzipped code in a folder and compile under Visual Studio without any problems - hopefully. If you have problems, let me know.
Attachments
VirtualTrackgen.zip
(23.05 KiB) Downloaded 510 times

Reason: No reason

9a4db
Posts: 29
Joined: Sun Jan 24, 2016 6:44 pm

Re: Virtual Trackgen

Post by 9a4db » Sat Jun 23, 2018 8:19 am

Thank You Steve,
will report results here.
73
Djani

Reason: No reason

9a4db
Posts: 29
Joined: Sun Jan 24, 2016 6:44 pm

Re: Virtual Trackgen

Post by 9a4db » Mon Jul 23, 2018 1:16 pm

Just to stop by to report that I finally managed firmware upgrade on my ERASynth+
On first try, unit was bricked by my mistake, but second with some support went ok.

Unit now working like charm, through USB/RS232 and direct terminal commands.

The W10 and WEB applications still have some bugs, hope upgrades will show up after some time...

Now can try to play with example zip from Steve ;)
ERAtrackGenON.jpg
ERAtrackGenON.jpg (356.16 KiB) Viewed 10943 times

Reason: No reason

SteveAndrew
Posts: 213
Joined: Thu Nov 16, 2017 11:06 pm
Location: Gold Coast, QLD, Australia

Re: Virtual Trackgen

Post by SteveAndrew » Tue Jul 24, 2018 12:37 am

9a4db wrote:Just to stop by to report that I finally managed firmware upgrade on my ERASynth+
Splendid news indeed. I look forward to seeing your results.

Phil - VK7JJ has sent me a link to the AD9910 module that is available on Ebay. I was considering using an AD9959 module, four channels at 200MHz per channel, but the AD9910 goes up to around 420MHz and is a similar price, so I'll be getting one of those instead. I was going to order it last week but decided that with the work in hand for the second release of the analyser, I'd put it off until I was ready to work on the trackgen system - It would have been an unnecessary distraction. Swamp-alligator syndrome :D It did strike me that if an unfiltered output was available, then invoking the magic of Mr Nyquist, it might be possible to use one or more of the aliases and perhaps extend the output to higher frequencies - just a thought...

https://www.ebay.com.au/itm/AD9910-DDS- ... SwfrxZ1vw3

Reason: No reason

bogdan
Posts: 3
Joined: Mon Mar 25, 2019 10:56 am

Re: Virtual Trackgen

Post by bogdan » Mon Mar 25, 2019 4:02 pm

AD9910 looks quite nice but are there any options for going over 1GHz under 100$?
Last edited by bogdan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

SteveAndrew
Posts: 213
Joined: Thu Nov 16, 2017 11:06 pm
Location: Gold Coast, QLD, Australia

Re: Virtual Trackgen

Post by SteveAndrew » Tue Mar 26, 2019 5:33 am

bogdan wrote:AD9910 looks quite nice but are there any options for going over 1GHz under 100$?
Not that I'm aware of at this time. It's bound to happen sooner or later, probably sooner than later with luck.

Steve

Reason: No reason

bogdan
Posts: 3
Joined: Mon Mar 25, 2019 10:56 am

Re: Virtual Trackgen

Post by bogdan » Wed Mar 27, 2019 5:18 am

How about the ADF4351 based boards? Would these be any good? They are supposed to work in the 35M-4.4G span.
https://www.aliexpress.com/item/35M-4-4 ... 82943.html
https://www.aliexpress.com/item/ADF4351 ... 05971.html
Last edited by bogdan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

SteveAndrew
Posts: 213
Joined: Thu Nov 16, 2017 11:06 pm
Location: Gold Coast, QLD, Australia

Re: Virtual Trackgen

Post by SteveAndrew » Thu Mar 28, 2019 1:35 am

bogdan wrote:How about the ADF4351 based boards? Would these be any good? They are supposed to work in the 35M-4.4G span.
Hi Bogdan

That looks very interesting, thank you for the links. Once I get the remaining debugging out of the way I'll get the data sheets and see what is possible.

Steve

Reason: No reason

Brian VK6LO
Posts: 8
Joined: Tue Jan 29, 2019 11:51 pm

Re: Virtual Trackgen

Post by Brian VK6LO » Mon Apr 01, 2019 7:16 am

Just received an Arduino UNO (compatible I believe) for my tracking generator
Installed Arduino IDE 1.8.9 but UNO driver failed to load however when I Update Driver through device manager it responds with a code 10 error - unable to start the driver

Operating system windows 7 home premium 64bit 2.7GHz dual core CPU 4GB ram

When connected the UNO board shows 2 red led's - ON and a flashing L

I have checked out the various "fixes" for the code 10 error but the driver still refuses to operate and that is as far as I have progressed

Wondering if anyone has further info on how to overcome my obstacle

Thanks
Brian
Last edited by Brian VK6LO on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Brian VK6LO
Posts: 8
Joined: Tue Jan 29, 2019 11:51 pm

Re: Virtual Trackgen

Post by Brian VK6LO » Tue Apr 02, 2019 9:35 am

False alarm - after the grey matter fired up and I 'discovered' the CH340 USB to Serial chip, downloaded the appropriate driver for it, everything seems back on track (no pun intended) for now anyway
Last edited by Brian VK6LO on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Post Reply