uVirtualhere and SDRUno

Discussions about everything to do with SDRuno
William
Posts: 1
Joined: Mon Apr 29, 2019 2:49 pm

uVirtualhere and SDRUno

Postby William » Mon Apr 29, 2019 2:59 pm

Hi

I have build my SDRplay with an raspbery pi and an virtualUSB server "virtualHere"
On my PC i'll want to run SDRuno via VirtualUSB client connected to the remote SDRPlay.

Probbely this setup is not supported. Get an errror from SDRuno "Device cannot be initialized" sdrplay_api_servicenotresponding

Is there a way to get this setup working ?
any clues ?

Reason: i want my SDRPlay as close at my antenna as possible to reduse cable losses
(try to receive 1 Ghz)

thanks in advance

regards,
William
Last edited by William on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

TD410
Posts: 2
Joined: Wed Mar 13, 2019 12:57 am

Re: uVirtualhere and SDRUno

Postby TD410 » Wed May 01, 2019 8:25 pm

Hi,

I'm watching this thread with interest.

I do use my RSP2 duo over USB via TCP/IP with UNO but only with limited sucess, the lastes release seems to have stopped it working though.
I've got as far as being able to use my RSP with a single tuner at 2MHz, with a tinkerboard as the client after a kernal recomplie and a lot of fiddling.
(A tinkerboard SBC will throw data around gigabit in excess of USB2 speeds unlike a Pi.)

Device of this nature uses a perticular mode of USB that not all "sharing" Apps support.

However, Using soapy, I can use the full 10MHz, so proves it is possible on my hardware. (tinkerboard/Cisco Managed switches with Fibre/Win10 Client.)

If a version of RSP with gigabit ethernet was put on the market, I'd probably buy two tomorrow !

Hope that helps some.
Mark
Last edited by TD410 on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Ian S
Posts: 3
Joined: Wed Jun 12, 2019 4:22 pm

Re: uVirtualhere and SDRUno

Postby Ian S » Wed Jun 12, 2019 5:53 pm

I’ve just spent a day playing with VirtualHere and my RSP2, and I’m not impressed.

My normal setup is Sdruno running on a Win 10 virtual machine under parallels on a Mac. I use a 10m repeated USB cable. This set up works very well. However I would like to remote my RSP away from the house to reduce noise.

I was drawn to VirtualHere because of the article linked from their website saying rtl dongles can be run remotely https://www.rtl-sdr.com/using-the-virtu ... e-rtl-sdr/ So I thought it should work with my RSP. VirtualHere appear to claim you can remote any USB device.

I’ve tried the basic VH app on a raspberry pi 3B and a 3B+, and none of my apps, Sdruno, cubic sdr and dump 1090, will see the RSP. nor will cubic sdr on my Mac see the won’t see the RSP. My pis are connected by an Ethernet cable to the same switch as my Mac. The VirtualHere client shows the RSP as a just a number rather than a device such as a mouse. My Win 10 VM manages to recognise it. As soon as I run Sdruno the rsp disappears from the list of USB devices and Sdruno fails to launching as it can’t see the RSP. Other dives say the api has failed.

I’ve also tried the VirtualHere CloudHub on a pi 3B. My Win 10 VM sees it and Sdruno runs, but the audio is horrible, and unusable. Cubic sdr runs, but again with poor audio. Again Cubic Sdr on my Mac can’t see the Rsp.

I’ve only used the free versions of VirtualHere, but as these have been totally useless I don’t think I’ll bother paying $49 for a device optimised version. If any of the tests were close to working I might have been tempted, or if someone has managed to get it to work please let me know and I might splash out for a full version.

So I think I’ll go down the rpi route to remote my rsp and use something like cubic sdr. My preference is to use , but that currently doesn’t support any form of remote connection.
Last edited by Ian S on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 9 guests