Page 1 of 1

New RSP1A .. nothing happens after install

Posted: Tue Jan 22, 2019 7:44 pm
by JayKay

(I also created a ticket .. and the bulk of it is here)

I just had this feeling this was not going to go smoothly with the RSP1A.

I got the RSP1A and installed the latest version of Uno (1.22) for the RSP1A. I have a Widows 7 Pro machine 64 bit. I followed the directions during the install and also a guy named Micheal's video who shows a complete startup

1) The software doesn't launch .. just a quick flash on the screen .. It then reports the RSP1 or something of that nature Not Found
2) It doesn't recognize its there even though Windows reports it READY FOR USE
3) I have tried the down load and install 4 times and it doesn't t see a thing
4) Device Manager shows nothing new installed for hardware
5) So I tried on the last attempt the universal way to ensure USB stuff gets going by rebooting the machine before plugging in the device. I install the software and then NOT launch the software. I then shut down the machine. I then booted back up assuming the software got installed right. I plug in the RSP1A and Windows reports initially UNIDENTIFIED then says READY FOR USE...OK...and..... the software just does nothing. When this goes I cannot shut down the PC. I have to go into a soft reboot, then immediately go to UNINSTALL programs in the Control Panel, delete the 2 SDR items shown, then the PC can shut down. So there is something in the install jamming up the works when this software never launches
6) This is ridiculous and I am really disappointed in this. My PC is nothing odd using standard ASUS stuff...has never rejected a program or USB compliant hardware in over 2 years
7) I have tried 2 USB cables.....

Quite annoyed

Re: New RSP1A .. nothing happens after install

Posted: Tue Jan 22, 2019 11:03 pm
by Tech_Support
Hello Jay,
I understand that your problem is now resolved.

Because of the real-time wideband nature of the data that the RSP has to support the chipset within our products use an isochronous mode transfer driver. This guarantees the necessary USB bandwidth irrespective of whatever USB peripherals are active on the same USB end-point. If we didn't use this mode, then other USB activity could lead to lost data packets across the USB interface.

Unfortunately it appears that some USB 3.0 chipsets do not do a good job of providing full backwards compatibility to USB 2.0. The alternative approach would have been to use a bulk mode driver and with bulk mode, if data is lost, it is simply resent. However, no specific bandwidth is guaranteed and the real-time nature of data transfer is lost. The vast majority of USB peripherals have no requirement for real-time data integrity and so use a bulk mode driver, which is why they are less likely to expose the implementation flaws of the chipset where full backwards compatibility to USB 2.0 is concerned.

Many USB 3.0 host controllers work just fine. The problem is that we have no way of knowing which ones do and which ones don't, so we recommend using a USB 2.0 port, but that doesn't automatically mean that a USB 3.0 or a hub wont.



Re: New RSP1A .. nothing happens after install

Posted: Wed Jan 23, 2019 11:37 am
by JayKay
Not quite...but thanks for the info,,,,I have (at least for now) got it to work with 3.0 but who knows whats being lost per your data....after shutting off machine, I pulled USB connector. I then started it up and then plugged into a 3.0 port and it saw stable...who knows...but there is a much larger issue and I am quite frustrated with Uno and Omnirig in working with DXLab. And DXlab I do not think is the issue as it sees my radio on COM2 all day long by itself and worked just fine with NaP3 and the LP-PAN adapter which nI want to set aside as the RSP1A could be interesting when not on the air.

I have VSPE paired to 10==>11

Uno set to com 10
DXlab set to com11
Omnirigi now online with SYNCH1 and shows #0..sometimes depending on VRX com assignment
TS590SG menu 69 set to USB for data communication

Uno sometimes connects in the VRX setup...

BUT I can to get some communications back and forth....and if I change a band, it just gets dumb depending on what port gets assigned to what program..

The freq readout in Uno tracks sometimes UNTIL I dare change bands from the TS590 but sometimes Uno can change the bands...sometimes. And sometimes the 590 can change bands.,..and sometimes Uno or Omonrig control just changes the mode only in the you can tell, I do not get who is talking to who in real time.

The big picture here is it does not work 100% in both least for me.

What is lacking is a typical flow diagram with these 3 programs (and it can HRD , DXLAB, etc) with com port assignments so us folks who just don't get it will see the flow of data. Right now its a ridiculous guessing game when something works and something does not and trying to figure out what in the world is going on with communication.

Its very frustrating and apparently I am not alone based on web searches.

Please proved a set of typical com assignments one would use and maybe a short explanation on who is talking to who when using Uno, Omnirig and (in my case ) DXlab Commander for its port configuration. Obviously the other rig control packages configurations appear to be quite similar regarding the CAT setups. And I think most would understand how to infer from the diagram how to configure the 3 properly if the com port in the diagram was presently in use in one's machine.....the inference of the diagram would lead us to see the flow and adjust our machines accordingly. Also mention any com changes need a reboot to set them up

I would certainly appreciate it .. and for me and others...just a simple diagram and explanation on the data flow of these 3 programs. A picture of a typical com assignment would shed a lot of light on this issue. I assume that all the settings for the com ports parameters, as a minimum, should match with Omnirig and the other 2.

Honestly I am exhausted trying to figure out why I get partial stuff in one direction, partial stuff in another direction and then sometime, partial stuff in both directions

Thanks in advance

pcb4u at ATT dot Net

Re: New RSP1A .. nothing happens after install

Posted: Fri Jan 25, 2019 1:38 am
by schefmar
Having pretty much the same problem. Any way to resolve this ? (I have also opened a ticket)