Page 1 of 1

rsp_tcp ignoring command line options?

Posted: Sat Aug 17, 2019 9:33 pm
by rack201
Hi -

I'm trying to setup my Rpi + RSP2 to stream samples across my network to another linux machine running the iridium decoder, so I can relocate the receiving gear to a better position. I thought rsp_tcp might be the answer. I set it up on the Pi and used netcat on the other box to pipe the stream to the decoder. I see a stream, but no decoding.

When I run rsp_tcp with verbose turned on, it looks like it is ignoring my command line sample rate and frequency settings (see below). I've tried both the binary and build options. Any ideas, or perhaps there is a better way to do what I'm looking for?


Code: Select all

pi@raspberrypi:~ $ rsp_tcp -a -p 3333 -s 8000000 -f 1622000000 -v -E
rsp_tcp version 1.0

libmirsdrapi-rsp version 2.13 found
mir_sdr_usb_GetDevices Dev0:vid=1df7 pid=3010 rev=0207 serno=1604002400 bus=001 port=003 devAvail=1
mir_sdr_usb_SetDeviceIdx idx=0 numDevices=1
Opened device with idVendor = 0x1df7 idProduct = 0x3010 fwVersion = 0x0207 busNum = 001 portNum = 003
mir_sdr_Init: starting hardware initialization
mir_sdr_Init: gR=60dB fs=2.000MHz rf=98.800MHz bw=1.536MHz if=0.000MHz
DownConvert: Enable=0 DecM=1 OutScale=0 (fs=2.000000 bw=1536 if=0)
initState: numActivePackets=4
mir_sdr_usb_USB DLL: Revision 0.1.1
mir_sdr_2500_Init: fnaddr = 11
mir_sdr_2500_Init: adjusting squelch trim 0x1, rx gating enable 1, tx_trim 0, reg2 = 0x4801
initHw: Register7 = 0x000014
initRfFreqDependentHw(1): Tuner Register0 = 0x04f420
mir_sdr_GpioExtWrite: Addr=0 Data=0x00
mir_sdr_GpioExtWrite: Addr=1 Data=0x00
mir_sdr_GpioExtWrite: Addr=18 Data=0x5d
mir_sdr_GpioExtWrite: Addr=19 Data=0xa5
initRfFreqDependentHw(1): ExtGpioA = 0x5d ExtGpioB = 0xa5
mir_sdr_SetFs: Sample Freq requested 2000000.000000
mir_sdr_SetFs: Fs->FsNomHz+dFsHz=2000000.0+0.0Hz=2000000.0Hz FsToggle->1
mir_sdr_SetRf: f->98799999.901Hz (int=20 frac=aef afc=fff) fSynth:3161599996.838
[color=#FF80BF]mir_sdr_SetRf: Rf->RfNomHz+dRfHz+LifHz+Lif1Hz=98800000.0+0.0+0.0Hz+0.0Hz=98799999.9Hz RfToggle->1[/color]
mir_sdr_SetGr: GR->60[36,24,0,0] gRset->0x224 DCCALmode=3 DCCALspd=0 GrToggle->1
No offset diff1=0x000000fc diff2=0x000000fc
No offset samp1=0x0000285e samp2=0x0000295a samp2=0x00002a56
setToggleStates: initialising sampNum=0x00017a02, gainSetting=0x224, FsToggle=0, RfToggle=1, GrToggle=1
setToggleStates: initialising Fs=2000000.000, Rf=98799999.901, Gr=60
mir_sdr_GpioExtWrite: Addr=19 Data=0xa5
mir_sdr_2500_Readback001Trim: readback = 0xe4c2c10
mir_sdr_2500_Bypass001Trim: reg13=0x20d reg14=0x7302ce
detected RSP model 'RSP 2' (hw ver 2)
mir_sdr_DCoffsetIQimbalanceControl: DC:1 IQ:1
mir_sdr_DecimateControl: 0 1 0
mir_sdr_DecimateControl: DecimateEnable=0, DecimateDecM=1, DecimateOutScale=0, DecimateRound[0]=0x00000000, DecimateRound[1]=0x00000000